Daily Email Delivery Delay
Incident Report for Squadle, Inc.
Resolved
Issue was resolved and all emails effected were resent by 11:45am
Posted Aug 27, 2020 - 14:30 EDT
Identified
The issue has been identified and a fix is in place to resend Daily Emails to affected users.
Posted Aug 27, 2020 - 11:16 EDT
Investigating
We are currently investigating an issue that has affected Daily Email delivery for some users this morning.
Posted Aug 27, 2020 - 10:39 EDT