Partial Service Outage
Incident Report for Squadle, Inc.
Postmortem

This issue was caused by an overloaded server crashing. Engineering team has resolved the issue to prevent it from happening again.

Posted Dec 03, 2018 - 11:22 EST

Resolved
Some tablets may not load checklist services as expected.

All services were restored within 40 minutes of downtime.
Posted Nov 12, 2018 - 06:00 EST