Reports of Squadle Hub Crashing
Incident Report for Squadle, Inc.
Resolved
This incident has been resolved.
Posted May 09, 2019 - 14:12 EDT
Identified
We have received reports this morning that the Squadle Hub application has been crashing for some users. We have identified the issue and are providing resolution immediately.
Posted May 09, 2019 - 12:18 EDT
This incident affected: Squadle Checklists/Workflows/RTS.